Back to overview
Degraded

Latency may impact user login and report signing

Feb 24, 2026 at 2:56pm UTC
Affected services
Reporting

Resolved
Feb 24, 2026 at 5:08pm UTC

The latency issue with Login and Report signing is resolved. FHIR connection has returned to normal, and we will continue to monitor.

Updated
Feb 24, 2026 at 4:06pm UTC

We have identified and resolved the login issues.
We are currently continuing working to resolve a secondary issue on report signing and completion.

Updated
Feb 24, 2026 at 3:37pm UTC

We have identified an issue with our FHIRcast integration, which is impacting context synchronization for some workflows, and causing increased load times when logging in and creating/signing reports. Our team is actively debugging and working to restore normal operation. We will provide the next update within 30 minutes or sooner as more information becomes available.

Created
Feb 24, 2026 at 2:56pm UTC

We are actively investigating a latency issue that may impact user login and report signing.