Back to overview
Degraded

We are currently experiencing latency and partial outages in the Omni Impression application. Our team is actively working to resolve the issue.

Dec 16 at 04:37pm UTC
Affected services
Omni Impressions

Resolved
Dec 16 at 05:03pm UTC

The issue causing latency and intermittent outages in Omni Impression has been resolved. All services are now operating normally.

Created
Dec 16 at 04:37pm UTC

We are currently experiencing latency and intermittent outages affecting the Omni Impression application. Users may notice delays in impression generation or periods where the application is unavailable. Our engineering team is actively investigating and working to restore normal performance.