HL7 Degradation
Resolved
Dec 03 at 08:32pm UTC
We have determined the root cause of the performance degradation as a missed maintenance window on our HL7 processing database. We've since performed the required maintenance and the database has fully recovered. We consider this incident to be resolved, but we're still monitoring the database closely.
Affected services
Updated
Dec 03 at 07:34pm UTC
We are still investigating the underlying causes, but we have not seen any more performance issues with HL7 ingestion. We will provide an update in the next hour.
Affected services
Updated
Dec 03 at 07:03pm UTC
We believe the performance degradation to be caused by slow database queries. We have applied a temporary fix to help with this performance degradation. We are still investigating the underlying issue and monitoring the database performance closely to ensure all HL7 is promptly ingested. We will provide an update in the next 30 minutes.
Affected services
Created
Dec 03 at 06:17pm UTC
We have processed all queued HL7 messages and are no longer seeing degraded performance. We are still investigating the underlying cause and will provide an update in the next 30 minutes.
Affected services