Back to overview
Maintenance
Scheduled Maintenance for Reporting: April 30, 2026 from 10:00 to 10:30 PM PST
May 1, 2026 at 5:00am UTC
–
May 1, 2026 at 5:30pm UTC
Affected services
Reporting
Nexus
Resolved
May 1, 2026 at 5:30pm UTC
Maintenance ended
Affected services
Created
May 1, 2026 at 5:00am UTC
We will be performing a scheduled maintenance on April 30, 2026, from 10-10:30pm PST, with some downtime expected during this window. We will be updating the clinical database during the maintenance period.
Reporting will be unavailable during this window. If you attempt to access Reporting during the maintenance period, please wait and retry after this window or follow the workaround in this Help Center article. There are no functional changes to Reporting as part of this work.
Affected services