Back to overview
Downtime
We are currently experiencing an outage affecting Reporting Client.
Mar 19, 2026 at 12:08am UTC
Affected services
Reporting
Resolved
Mar 19, 2026 at 12:35am UTC
Services to the Reporting Client have been fully restored.
Affected services
Created
Mar 19, 2026 at 12:08am UTC
Rad AI is currently down due to an ongoing issue. Our team is actively working on a fix and will provide updates shortly.
Affected services