Back to overview
Degraded

Impression timeouts

Mar 5, 2026 at 3:56pm UTC
Affected services
Omni Impressions

Resolved
Mar 5, 2026 at 6:50pm UTC

We have identified the root cause of the Omni Impression generation problem, and the issue is now resolved. Impressions should now be functioning as intended. Thank you!

Created
Mar 5, 2026 at 3:56pm UTC

We are seeing an increased number of timeouts for the Impressions service. Our teams are investigating.