Back to overview
Downtime
Reporting inaccessible for some users
May 22 at 03:36pm UTC
Affected services
Reporting
Resolved
May 22 at 04:06pm UTC
All services are back up.
Affected services
Created
May 22 at 03:36pm UTC
Certain functions of Reporting are inaccessible for some users. Our team is currently investigating.
Affected services