Back to overview
Degraded

Some Impressions models temporarily unavailable

Nov 07 at 10:38pm UTC
Affected services
Omni Impressions

Resolved
Nov 08 at 12:24am UTC

We have resolved the earlier model issue and Rad AI Impressions should be functioning normally for all users

Created
Nov 07 at 10:38pm UTC

We are aware of an issue affecting some users of Rad AI Impressions. Our team is investigating and implementing a temporary workaround.