Back to overview
Resolved
HL7 Processing issues
Sep 2, 2026 at 10:22pm UTC
Affected services
Reporting
Resolved
Sep 2, 2026 at 10:54pm UTC
Our engineers have identified and fixed the issue and will continue to monitor.
Affected services
Created
Sep 2, 2026 at 10:22pm UTC
We are aware of issues affecting HL7 and are actively investigating. We will provide updates as more information becomes available.
Affected services